Windows实例安装系统更新后, 无法启动或功能异常怎么办?

本文介绍Windows实例安装系统更新后无法启动的问题原因和解决方案。

问题现象

Windows实例安装系统更新后,系统无法正常启动或Windows功能(驱动安装失败,KMS服务异常等)出现异常。

问题原因

出现该问题可能是该实例安装了存在缺陷的系统补丁,导致操作系统无法正常启动或Windows功能异常。

解决方案

您可以根据实例是否可以正常启动,选择合适的方式卸载系统补丁。

实例可以正常启动

方法一:在Windows更新中卸载系统补丁

  1. 远程连接ECS实例。

    具体操作,请参见通过密码或密钥认证登录Windows实例

  2. 单击开始菜单,然后单击设置

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  3. Windows设置界面,单击更新和安全

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  4. Windows更新界面,单击查看更新历史记录

    image.png

  5. 查看更新历史记录界面,单击卸载更新

    image.png

  6. 右键单击要卸载的更新(例如KB5029250),单击卸载(U),根据页面提示,卸载该更新。

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方法二:使用PowerShell卸载系统补丁

  1. 远程连接ECS实例。

    具体操作,请参见通过密码或密钥认证登录Windows实例

  2. 以管理员身份运行Windows PowerShell

    image.png

  3. 查找补丁对应的软件包。

    $package = Get-WindowsPackage -Online | Where-Object {$_.PackageName -match 'KB5029250'}
  4. 卸载软件包。

    $package | Remove-WindowsPackage -Online

实例无法正常启动

实例无法正常启动时,您可以对问题实例挂载修复盘,然后在实例中卸载异常补丁以修复该问题。假设挂载盘符为D,要卸载的补丁是KB5029250,卸载异常补丁步骤如下:

  1. 发起实例操作系统无法启动诊断。

    1. 登录ECS管理控制台

    2. 在左侧导航栏,单击自助问题排查

    3. 在顶部菜单栏左上角处,选择地域。

    4. 实例问题排查页签,单击实例无法连接或启动异常问题类型。

    5. 选择实例状态为已停止,无法正常启动问题、需要诊断的实例ID及时间范围,然后单击开始排查

      说明

      需要诊断的ECS实例必须处于已停止状态,具体操作,请参见停止实例

      实例健康诊断

      诊断完成后,实例处于运行中修复中状态。

      运行中、修复中

  2. 远程连接有问题的实例。

    您可以在诊断结果界面单击VNC远程连接,使用诊断报告中提供的临时登录实例的Administrator用户及密码信息登录挂载了修复盘的ECS实例。具体操作,请参见使用VNC登录实例

  3. 以管理员身份运行Windows PowerShell

    image.png

  4. 查找补丁对应的软件包。

    $package = Get-WindowsPackage -Path D:\ | Where-Object {$_.PackageName -match 'KB5029250'}
  5. 卸载软件包。

    $package | Remove-WindowsPackage -Path D:\
  6. 在实例列表页,将鼠标悬浮至修复中的状态上,然后单击卸载修复盘

    卸载修复盘

  7. 重启实例,使以上配置生效。

    具体操作,请参见重启实例

  8. 远程连接ECS实例,如果该实例可以正常连接,说明问题已修复。

    具体操作,请参见通过密码或密钥认证登录Windows实例