本文介绍Windows实例安装系统更新后无法启动的问题原因和解决方案。
问题现象
Windows实例安装系统更新后,系统无法正常启动或Windows功能(驱动安装失败,KMS服务异常等)出现异常。
问题原因
出现该问题可能是该实例安装了存在缺陷的系统补丁,导致操作系统无法正常启动或Windows功能异常。
解决方案
您可以根据实例是否可以正常启动,选择合适的方式卸载系统补丁。
实例可以正常启动
方法一:在Windows更新中卸载系统补丁
远程连接ECS实例。
具体操作,请参见通过密码或密钥认证登录Windows实例。
单击开始菜单,然后单击设置。
在Windows设置界面,单击更新和安全。
在Windows更新界面,单击查看更新历史记录。
在查看更新历史记录界面,单击卸载更新。
右键单击要卸载的更新(例如KB5029250),单击卸载(U),根据页面提示,卸载该更新。
方法二:使用PowerShell卸载系统补丁
远程连接ECS实例。
具体操作,请参见通过密码或密钥认证登录Windows实例。
以管理员身份运行Windows PowerShell。
查找补丁对应的软件包。
$package = Get-WindowsPackage -Online | Where-Object {$_.PackageName -match 'KB5029250'}
卸载软件包。
$package | Remove-WindowsPackage -Online
实例无法正常启动
实例无法正常启动时,您可以对问题实例挂载修复盘,然后在实例中卸载异常补丁以修复该问题。假设挂载盘符为D,要卸载的补丁是KB5029250
,卸载异常补丁步骤如下:
发起实例操作系统无法启动诊断。
远程连接有问题的实例。
您可以在诊断结果界面单击VNC远程连接,使用诊断报告中提供的临时登录实例的Administrator用户及密码信息登录挂载了修复盘的ECS实例。具体操作,请参见使用VNC登录实例。
以管理员身份运行Windows PowerShell。
查找补丁对应的软件包。
$package = Get-WindowsPackage -Path D:\ | Where-Object {$_.PackageName -match 'KB5029250'}
卸载软件包。
$package | Remove-WindowsPackage -Path D:\
在实例列表页,将鼠标悬浮至修复中的状态上,然后单击卸载修复盘。
重启实例,使以上配置生效。
具体操作,请参见重启实例。
远程连接ECS实例,如果该实例可以正常连接,说明问题已修复。
具体操作,请参见通过密码或密钥认证登录Windows实例。